The given block of IP address is divided into different subnet for the development of the IP addressing plan and configure the interface of the router according to the IP addressing plan. The router is configured following the EIGRP routing protocol and a prototype of the network is configured in cisco packet tracer 7.2 for the identification of the errors in the network. The network is tested with running the ping command such that it can be tested to reach different address in the network.
Device |
Interface |
Addresses |
Default Gateway |
mR202 |
Fa0/0 |
ab12:1534:0000:A::1/64 |
N/A |
S0/0/0 |
ab12:1534:0000:12::1/64 FE80::1 link-local |
N/A |
|
S0/0/1 |
ab12:1534:0000:13::1/64 FE80::1 link-local |
N/A |
|
S0/1/0 |
ab12:1534:0000:14::1/64 FE80::1 link-local |
N/A |
|
PC2 int/1 |
NIC |
ab12:1534:0000:A::3/64 FE80::201:64FF:FEA6:A8D8 |
ab12:1534:0000:A::1 |
Server1 |
NIC |
ab12:1534:0000:A::4/64 FE80::201:C7FF:FE9E:6BC2 |
ab12:1534:0000:A::1 |
Device |
Interface |
Addresses |
Default Gateway |
mR204 |
Fa0/0 |
ab12:1534:0000:B::1/64 |
N/A |
S0/0/0 |
ab12:1534:0000:12::2/64 FE80::2 link-local |
N/A |
|
S0/0/1 |
ab12:1534:0000:23::2/64 FE80::2 link-local |
N/A |
|
PC4 int/1 |
NIC |
ab12:1534:0000:B::3/64 FE80::204:9AFF:FE16:1B2C |
ab12:1534:0000:B::1 |
Server2 |
NIC |
ab12:1534:0000:B::4/64 FE80::204:9AFF:FE8B:3EC2 |
ab12:1534:0000:B::1 |
Device |
Interface |
Addresses |
Default Gateway |
mR203 |
Fa0/0 |
ab12:1534:0000:C::1/64 |
N/A |
S0/0/0 |
ab12:1534:0000:13::3/64 FE80::3 link-local |
N/A |
|
S0/0/1 |
ab12:1534:0000:23::3/64 FE80::3 link-local |
N/A |
|
PC3 int/1 |
NIC |
ab12:1534:0000:C::3/64 FE80::260:70FF:FE9B:3754 |
ab12:1534:0000:C::1 |
Server2 |
NIC |
ab12:1534:0000:C::4/64 FE80::201:43FF:FE17:E473 |
ab12:1534:0000:C::1 |
Device |
Interface |
Addresses |
Default Gateway |
mR201 |
S0/0/0 |
ab12:1534:0000:D::1/64 FE80::4 link-local |
N/A |
Fa0/0 |
ab12:1534:0000:23::4/64 |
N/A |
|
PC1 int/1 |
NIC |
ab12:1534:0000:D::3/64 |
FE80::4 |
Server2 |
NIC |
ab12:1534:0000:D::4/64 |
FE80::4 |
mR201
int s0/0/0
ip add 150.50.34.1 255.255.255.252
clock rate 72000
no shut
exit
int fa 0/0
ip add 150.50.34.98 255.255.255.248
no shut
exit
router ospf 1
network 150.50.34.0 0.0.0.255 area 0
exit
exit
copy running-config startup-config
mR202
int s0/0/0
ip add 150.50.34.2 255.255.255.252
clock rate 72000
no shut
exit
int fa 0/0
ip add 150.50.34.17 255.255.255.248
no shut
exit
router ospf 1
network 150.50.34.0 0.0.0.255 area 0
exit
exit
copy running-config startup-config
mR202
ipv6 unicast-routing
ipv6 router eigrp 1
eigrp router-id 1.1.1.1
exit
int s0/0/1
ipv6 enable
ipv6 address ab12:1534:0000:13::1/64
ipv6 eigrp 1
exit
int s0/1/0
ipv6 enable
ipv6 address ab12:1534:0000:14::1/64
ipv6 eigrp 1
exit
int fa 0/0
ipv6 enable
ipv6 address ab12:1534:0000:A::1/64
ipv6 eigrp 1
exit
mR203
ipv6 unicast-routing
ipv6 router eigrp 1
eigrp router-id 2.2.2.2
int s0/0/0
ipv6 enable
ipv6 address ab12:1534:0000:13::3/64
ipv6 eigrp 1
exit
int s0/0/1
ipv6 enable
ipv6 address ab12:1534:0000:23::3/64
ipv6 eigrp 1
exit
int fa 0/0
ipv6 enable
ipv6 address ab12:1534:0000:C::1/64
ipv6 eigrp 1
exit
mR204
ipv6 unicast-routing
ipv6 router eigrp 1
eigrp router-id 3.3.3.3
int s0/0/0
ipv6 enable
ipv6 address ab12:1534:0000:12::2/64
ipv6 eigrp 1
exit
int s0/0/1
ipv6 enable
ipv6 address ab12:1534:0000:23::2/64
ipv6 eigrp 1
exit
int fa 0/0
ipv6 enable
ipv6 address ab12:1534:0000:B::1/64
ipv6 eigrp 1
exit
Th HQ router is configured with NAT -PT such that it can connect with the Ipv4 and Ipv6 networks. With the help of the network address translation the Ipv6 device can communicate with the device that are configured with IPv4 address. It can create a direct communication with the different types of network and based on static routing. A IPv6 NAT network is created between the HQ and the Branch C, tested and verified for the establishment of the connectivity. The configuration command used for the configuration of the router is given below:
hostname HQ
ipv6 unicast-routing
!
ip address 150.50.34.1 255.255.255.252
duplex auto
speed auto
ipv6 nat
!
interface Serial0/0/1
no ip address
duplex auto
speed auto
ipv6 address ab12:1534:0000:13::1/64
ipv6 enable
!
interface Serial0/1/0
no ip address
duplex auto
speed auto
ipv6 address ab12:1534:0000:14::1/64
ipv6 enable
!
ipv6 route ::/0 ab12:1534:0000::10
ipv6 nat v4v6 source 150.50.34.98 ab12:1534:0000:23::4
!— Translates the ipv4 add of R2 fa0/0 to ipv6 address.
ipv6 nat v6v4 source ab12:1534:0000:A::1 150.50.34.17
ipv6 nat prefix ab12::/64
!— The destination prefixes that matches ab12::/64
!— are translated by NAT-PT.
!
end
For the verification of the configuration of the router and enabling communication between the branches the configuration is verified by pinging the device connected with the different router interface. The show command is used for the demonstration of the configuration and IP address use for the configuration of the interface. The
HQ#ping AB12:1534:0:A::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to AB12:1534:0:A::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms
The HQ router is pinged with the IPv6 address of the PC for testing the communication between the PC and the router interface.
The configuration of the router for the branch is verified using the “show ip interface brief” command and it shows the IP address assigned to the different interface of the router and used for communicating with the other branch.
HQ#show ipv6 nat translations
Prot IPv4 source IPv6 source
IPv4 destination IPv6 destination
— — —
— 150.50.34.98 AB12:1534:0:23::4
— 150.50.34.17 AB12:1534:0:A::1
— — —
HQ#
The HQ router is configured with NAT such that it is able to communicate with the branch C which is configured with IPv4 network address.
The IP interface brief command is used for the configuration of the H router and the details of the IP address assigned to the interface of the router is demonstrated in the above screenshot.
The following screenshot is given for the demonstration of the ping tests and verification of the connectivity between the server and the P connected with the router interface of each of the branches.
For the real life deployment Branch C and HQ is selected and the commands used for the configuration of the router are given below:
mR201 (Branch C)
int s0/0/0
ip add 150.50.34.2 255.255.255.252
clock rate 72000
no shut
exit
int fa 0/0
ip add 150.50.34.98 255.255.255.248
no shut
exit
router ospf 1
network 150.50.34.0 0.0.0.255 area 0
exit
copy running-config startup-config
mR202 (HQ Router)
ipv6 unicast-routing
ipv6 router eigrp 1
eigrp router-id 1.1.1.1
exit
int s0/0/0
ip add 150.50.34.1 255.255.255.252
clock rate 72000
no shut
exit
int fa 0/0
ip add 150.50.34.17 255.255.255.248
no shut
exit
router ospf 1
network 150.50.34.0 0.0.0.255 area 0
exit
exit
conf t
int s0/0/1
ipv6 enable
ipv6 address ab12:1534:0000:13::1/64
ipv6 eigrp 1
exit
int s0/1/0
ipv6 enable
ipv6 address ab12:1534:0000:14::1/64
ipv6 eigrp 1
exit
int fa 0/0
ipv6 enable
ipv6 address ab12:1534:0000:A::1/64
ipv6 eigrp 1
exit
ipv6 route ::/0 ab12:1534:0000::10
ipv6 nat v4v6 source 150.50.34.98 ab12:1534:0000:23::4
ipv6 nat v6v4 source ab12:1534:0000:A::1 150.50.34.17
ipv6 nat prefix ab12::/64
copy running-config startup-config
Akilandeswari, D., Rabara, S.A. and Bai, T.D.P., 2017, February. Enhanced Security Architecture for IPv6 Transition. In Computing and Communication Technologies (WCCCT), 2017 World Congress on (pp. 61-64). IEEE.
Akour, I., 2016. Between Transition from IPv4 and IPv6 Adaption: The Case of Jordanian Government. INTERNATIONAL JOURNAL OF ADVANCED COMPUTER SCIENCE AND APPLICATIONS, 7(9), pp.248-252.
Chen, I., Lindem, A. and Atkinson, R., 2016. OSPFv3 over IPv4 for IPv6 Transition (No. RFC 7949).
Chown, T. and Gont, F., 2016. Network reconnaissance in IPv6 networks.
Chuangchunsong, N., Kamolphiwong, S., Kamolphiwong, T., Elz, R. and Pongpaibool, P., 2014, February. Performance evaluation of IPv4/IPv6 transition mechanisms: IPv4-in-IPv6 tunneling techniques. In Information Networking (ICOIN), 2014 International Conference on (pp. 238-243). IEEE.
Cui, Y., Wang, W., Sun, Q., Li, L. and Wang, X., 2015. IPv4 Address Sharing and Allocation for IPv6 Transition. IEEE Internet Computing, 19(5), pp.66-71.
El Khadiri, K., Labouidya, O., Elkamoun, N. and Hilal, R., 2018. Performance Analysis of Video Conferencing over Various IPv4/IPv6 Transition Mechanisms. INTERNATIONAL JOURNAL OF COMPUTER SCIENCE AND NETWORK SECURITY, 18(7), pp.83-88.
Foremski, P., Plonka, D. and Berger, A., 2016, November. Entropy/ip: Uncovering structure in ipv6 addresses. In Proceedings of the 2016 Internet Measurement Conference(pp. 167-181). ACM.
Gont, F. and Chown, T., 2016. Network Reconnaissance in IPv6 Networks (No. RFC 7707).
Hamadneh, N. and Murray, D., 2017, August. Private subnetting one (PS1), an algorithm for private IPv4 address allocation. In Proceedings of the 7th International Conference on Information Communication and Management (pp. 40-44). ACM.
Jafarian, J.H., Al-Shaer, E. and Duan, Q., 2015. An effective address mutation approach for disrupting reconnaissance attacks. IEEE Transactions on Information Forensics and Security, 10(12), pp.2562-2577.
Kalwar, S., Bohra, N. and Memon, A.A., 2015, February. A survey of transition mechanisms from IPv4 to IPv6—Simulated test bed and analysis. In Digital Information, Networking, and Wireless Communications (DINWC), 2015 Third International Conference on (pp. 30-34). IEEE.
Kim, P.S., 2017. Analysis and Comparison of Tunneling based IPv6 Transition Mechanisms. International Journal of Applied Engineering Research, 12(6), pp.894-897.
Klein, D., Rehtanz, C., Hackstein, L. and Stütz, S., 2017, September. An integrated optimization approach for multi-voltage level network expansion planning. In Innovative Smart Grid Technologies Conference Europe (ISGT-Europe), 2017 IEEE PES (pp. 1-6). IEEE.
Lin, J.J., Wang, K.C., Cheng, S.M. and Liu, Y.C., 2017, August. On exploiting SDN to facilitate IPv4/IPv6 coexistence and transition. In Dependable and Secure Computing, 2017 IEEE Conference on (pp. 473-474). IEEE.
Newman, M., 2018. Networks. Oxford university press.
Pickard, J.L. and Patrick, A.Y., 2015, April. Workshop: IPv6 address planning. In SoutheastCon 2015 (pp. 1-2). IEEE.
Plonka, D. and Berger, A., 2015, October. Temporal and spatial classification of active ipv6 addresses. In Proceedings of the 2015 Internet Measurement Conference (pp. 509-522). ACM.
Salmanian, M., Pase, W., Brown, J.D. and McKenzie, C., 2017. A Gateway Prototype for Coalition Tactical MANETs. In Ad Hoc Networks (pp. 330-341). Springer, Cham.
Ziegler, S. and Ladid, L., 2016, March. Towards a Global IPv6 Addressing Model for the Internet of Things. In 2016 30th International Conference on Advanced Information Networking and Applications Workshops (WAINA) (pp. 622-627). IEEE.
Essay Writing Service Features
Our Experience
No matter how complex your assignment is, we can find the right professional for your specific task. Contact Essay is an essay writing company that hires only the smartest minds to help you with your projects. Our expertise allows us to provide students with high-quality academic writing, editing & proofreading services.Free Features
Free revision policy
$10Free bibliography & reference
$8Free title page
$8Free formatting
$8How Our Essay Writing Service Works
First, you will need to complete an order form. It's not difficult but, in case there is anything you find not to be clear, you may always call us so that we can guide you through it. On the order form, you will need to include some basic information concerning your order: subject, topic, number of pages, etc. We also encourage our clients to upload any relevant information or sources that will help.
Complete the order formOnce we have all the information and instructions that we need, we select the most suitable writer for your assignment. While everything seems to be clear, the writer, who has complete knowledge of the subject, may need clarification from you. It is at that point that you would receive a call or email from us.
Writer’s assignmentAs soon as the writer has finished, it will be delivered both to the website and to your email address so that you will not miss it. If your deadline is close at hand, we will place a call to you to make sure that you receive the paper on time.
Completing the order and download